FAQ

MEF Center Installation Fails When Importing the Base Image

Symptom

The user fails to install MEF Center by importing the local Ubuntu:22.04 base image using the docker load command.

Root Cause Analysis

When the Docker version in the MEF Center installation environment is 23.0 or later, Docker enables BuildKit by default as the image building tool to build images and re-obtains the dependent base images through the image registry. When MEF Center builds the dependent base image Ubuntu:22.04, if the image registry configured in the environment or the Docker public image registry is unavailable, and the base image is obtained through offline import, the MEF Center component image build will fail, resulting in the failure of MEF Center installation.

Solution

Before installing MEF Center, run the following command to disable the Docker BuildKit feature by setting an environment variable.

export DOCKER_BUILDKIT=0

MEF Edge Starts or Stops Repeatedly

Symptom

After the MEF Edge software has started or stopped, executing the start or stop command repeatedly will return a warning prompt. An example of the echo is shown below.

  • Repeated start

    warning: component [edge-om] is already started!
    warning: component [edge-main] is already started!
    warning: component [edgecore] is already started!
    warning: component [device-plugin] is already started!
    
  • Repeated stop

    warning: component [edge-om] is already stopped!
    warning: component [edge-main] is already stopped!
    warning: component [edgecore] is already stopped!
    warning: component [device-plugin] is already stopped!
    

Solution

This prompt will not appear if the start or stop command is not executed repeatedly.

Restoring the MEF Center Upgrade Environment After Forced Termination

Symptom

During the MEF Center upgrade, if the upgrade is forcibly terminated due to device power-on/power-off or other exceptions, you need to clear the image and node labels to restore the environment.

Solution

  1. Log in to the device environment.

  2. Run the following command to restore the upgrade environment.

    run.sh start
    

Restoring the MEF Edge Upgrade Environment After Forced Termination

Symptom

During the MEF Edge upgrade, the upgrade is forcibly terminated due to device power-on/power-off or other exceptions. In this case, the environment needs to be restored.

Solution

  1. Log in to the device environment.

  2. If the residual file "/home/data/mefedge/unpack/edge_installer" exists, delete it.

  3. Check the current MEF Edge version. If the upgrade was unsuccessful, perform the upgrade again.

    • Run the following command to enter the installation directory.

      cd MEFEdge installation path/MEFEdge/software
      
    • Run the following command to view the MEF Edge version in the version.xml file.

      cat version.xml
      
  4. If the MEF Edge version in version.xml is the target version, run the following command to restore the upgrade environment.

    run.sh start
    

Node Pressure Eviction Mechanism Causes MEF Center to Run Abnormally

Symptom

When deploying and running MEF Center, K8s triggers the node pressure eviction mechanism due to insufficient node resources such as memory, disk, and PID, causing MEF Center services to fail to run normally.

Root Cause Analysis

The node pressure eviction mechanism caused MEF Center-related images to be evicted.

Solution

  1. Clean up space to ensure sufficient capacity, and ensure that the remaining disk space of "/var/lib/docker" is no less than 10%.
  2. Uninstall MEF Center, then reinstall MEF Center and restart the MEF Center service.
    • If uninstalling MEF Center fails, perform the uninstall operation again.
    • If restarting MEF Center fails, run docker images to check for evicted images, navigate to the corresponding image path "MEF Center installation path/MEF-Center/mef-center/images/module name/image", manually execute docker load -i image name, and then restart MEF Center to recover.

MEF Edge Log Refreshing

Symptom

After MEF Edge successfully connects to CloudCore, edge_main generates a large number of messages, causing log flooding.

edgecore proxy receive msg router: {Source: Destination:EdgeCore Option:query Resource:default/node/***}, route: {Source:edge_main Group:resource Operation:response Resource:default/node/***}

Root Cause Analysis

The kube-controller-manager has not assigned a CIDR to the node, and edgecore will keep querying the node status until a CIDR is assigned.

Solution

  1. Log in to the host where MEF Center is installed.

  2. Modify the kube-controller-manager configuration file and configure the startup parameters of kube-controller-manager: cluster-cidr and allocate-node-cidrs.

    The kube-controller-manager configuration file is usually located at /etc/kubernetes/manifests/kube-controller-manager.yaml

    Example:

    --cluster-cidr=192.168.0.0/16
    --allocate-node-cidrs=true