Welcome To openEuler Community
Hey @liikii , thanks for your contribution to the community.
Bot Usage Manual
I'm the Bot here serving you. You can find the instructions on how to interact with me at Here . That means you can comment below every pull request or issue to trigger Bot Commands.
Contact Guide
If you have any questions, please contact the SIG: sig-CloudNative ,
and any of the maintainers: @duguhaotian, @gaodaweiky, @jimmieme, @lu-wei-army, @weibaohui, @wonleing, @yangzhao_kl, @zhaoyifan28, @zmr_2020 ,
and any of the committers: @Yekelu .


以下的要求不是强制性的, 未按模板评论时对issue无任何影响
issue处理注意事项:
1. 当前issue受影响的分支提交pr时, 须在pr描述中填写当前issue编号进行关联, 否则无法关闭当前issue;
2. 模板内容需要填写完整, 无论是受影响或者不受影响都需要填写完整内容,未引入的分支不需要填写, 否则无法关闭当前issue;
3. 以下为模板中需要填写完整的内容, 请复制到评论区回复, 注: 内容的标题名称(影响性分析说明, 缺陷严重等级, 受影响版本排查(受影响/不受影响), 修复是否涉及abi变化(是/否))不能省略,省略后defect-manager将无法正常解析填写内容.
评论区可能使用到的指令说明:
| 指令 | 指令说明 | 使用权限 |
|---|---|---|
| /check-issue | 触发defect-manager校验 | 不限 |
| /reason xxx | /reason +挂起或取消条件 | 不限 |
影响性分析说明:
缺陷严重等级:(Critical/High/Moderate/Low)
缺陷根因说明:
受影响版本排查(受影响/不受影响):
- openEuler-20.03-LTS-SP4:
- openEuler-22.03-LTS-SP3:
- openEuler-22.03-LTS-SP4:
- openEuler-24.03-LTS:
- openEuler-24.03-LTS-SP1:
- openEuler-24.03-LTS-SP2:
abi变化(是/否):
- openEuler-20.03-LTS-SP4:
- openEuler-22.03-LTS-SP3:
- openEuler-22.03-LTS-SP4:
- openEuler-24.03-LTS:
- openEuler-24.03-LTS-SP1:
- openEuler-24.03-LTS-SP2:
缺陷issue处理具体操作请参考:
https://atomgit.com/openeuler/cve-manager/blob/master/cve-vulner-manager/doc/md/defect-manager-manual.md
pr关联issue具体操作请参考:
https://docs.atomgit.com/docs/help/home/org_project/pullrequests/pr-related-issue


请按照系统提示的命令给一下docker-engine安装失败具体的报错日志信息@liikii
See "systemctl status docker.service" and "journalctl -xeu docker.service" for details.


请按照系统提示的命令给一下docker-engine安装失败具体的报错日志信息@liikii
See "systemctl status docker.service" and "journalctl -xeu docker.service" for details.
rc2 还有类似问题, 你看下
[root@localhost ~]#
[root@localhost ~]#
[root@localhost ~]# yum install docker-engine
Last metadata expiration check: 2:06:58 ago on Thu 27 Aug 2026 07:30:46 AM CST.
Dependencies resolved.
==============================================================================================================================================================================================================================================================================
Package Architecture Version Repository Size
==============================================================================================================================================================================================================================================================================
Installing:
docker-engine aarch64 2:18.09.0-354.oe2609 OS 34 M
Installing dependencies:
libnetwork aarch64 25.0.14-2.oe2609 OS 806 k
libtool-ltdl aarch64 2.5.4-3.oe2609 OS 32 k
Transaction Summary
==============================================================================================================================================================================================================================================================================
Install 3 Packages
Total download size: 35 M
Installed size: 144 M
Is this ok [y/N]: y
Downloading Packages:
(1/3): libtool-ltdl-2.5.4-3.oe2609.aarch64.rpm 636 kB/s | 32 kB 00:00
(2/3): libnetwork-25.0.14-2.oe2609.aarch64.rpm 7.7 MB/s | 806 kB 00:00
(3/3): docker-engine-18.09.0-354.oe2609.aarch64.rpm 40 MB/s | 34 MB 00:00
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total 41 MB/s | 35 MB 00:00
retrieving repo key for OS unencrypted from http://172.168.131.94:9400/repo_list/iteration.repo/openEuler-26.09-DevStation/rc2_openeuler-2026-08-24-07-58-15/26.09-with-kernel-6.6/OS/aarch64/RPM-GPG-KEY-openEuler
OS 2.5 MB/s | 3.0 kB 00:00
Importing GPG key 0xB675600B:
Userid : "openeuler <openeuler@compass-ci.com>"
Fingerprint: 8AA1 6BF9 F2CA 5244 010D CA96 3B47 7C60 B675 600B
From : http://172.168.131.94:9400/repo_list/iteration.repo/openEuler-26.09-DevStation/rc2_openeuler-2026-08-24-07-58-15/26.09-with-kernel-6.6/OS/aarch64/RPM-GPG-KEY-openEuler
Is this ok [y/N]: y
Key imported successfully
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
Preparing : 1/1
Installing : libtool-ltdl-2.5.4-3.oe2609.aarch64 1/3
Installing : libnetwork-25.0.14-2.oe2609.aarch64 2/3
Installing : docker-engine-2:18.09.0-354.oe2609.aarch64 3/3
Running scriptlet: docker-engine-2:18.09.0-354.oe2609.aarch64 3/3
[sss_cache] [sss_tool_confdb_init] (0x0010): Can't access '/var/lib/sss/db/config.ldb', probably SSSD isn't configured
Can't find configuration db, was SSSD configured and run?
[sss_cache] [sss_tool_confdb_init] (0x0010): Can't access '/var/lib/sss/db/config.ldb', probably SSSD isn't configured
Can't find configuration db, was SSSD configured and run?
Created symlink /etc/systemd/system/multi-user.target.wants/docker.service → /usr/lib/systemd/system/docker.service.
Job for docker.service failed because the control process exited with error code.
See "systemctl status docker.service" and "journalctl -xeu docker.service" for details.
Verifying : docker-engine-2:18.09.0-354.oe2609.aarch64 1/3
Verifying : libnetwork-25.0.14-2.oe2609.aarch64 2/3
Verifying : libtool-ltdl-2.5.4-3.oe2609.aarch64 3/3
Installed:
docker-engine-2:18.09.0-354.oe2609.aarch64 libnetwork-25.0.14-2.oe2609.aarch64 libtool-ltdl-2.5.4-3.oe2609.aarch64
Complete!
[root@localhost ~]# systemctl status docker.service
× docker.service - Docker Application Container Engine
Loaded: loaded (/usr/lib/systemd/system/docker.service; enabled; preset: disabled)
Active: failed (Result: exit-code) since Thu 2026-08-27 09:37:52 CST; 16s ago
Docs: https://docs.docker.com
Main PID: 2594 (code=exited, status=1/FAILURE)
CPU: 146ms
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.918987450+08:00" level=warning msg="mountpoint for pids not found"
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.919011750+08:00" level=warning msg="mountpoint for files not found"
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.919765950+08:00" level=info msg="stopping event stream following graceful shutdown" error="context canceled" module=libcontainerd namespace=plugins.moby
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.922941710+08:00" level=info msg="stopping healthcheck following graceful shutdown" module=libcontainerd
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.923944120+08:00" level=info msg="pickfirstBalancer: HandleSubConnStateChange: 0x2e0fd7fd0050, TRANSIENT_FAILURE" module=grpc
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.923971410+08:00" level=info msg="pickfirstBalancer: HandleSubConnStateChange: 0x2e0fd7fd0050, CONNECTING" module=grpc
Aug 27 09:37:52 localhost.localdomain dockerd[2594]: Error starting daemon: Devices cgroup isn't mounted
Aug 27 09:37:52 localhost.localdomain systemd[1]: docker.service: Main process exited, code=exited, status=1/FAILURE
Aug 27 09:37:52 localhost.localdomain systemd[1]: docker.service: Failed with result 'exit-code'.
Aug 27 09:37:52 localhost.localdomain systemd[1]: Failed to start Docker Application Container Engine.
[root@localhost ~]#
[root@localhost ~]#
[root@localhost ~]# journalctl -xeu docker.service
Aug 27 09:37:51 localhost.localdomain dockerd[2599]: time="2026-08-27T09:37:51.694237550+08:00" level=info msg="loading plugin \"io.containerd.grpc.v1.healthcheck\"..." type=io.containerd.grpc.v1
Aug 27 09:37:51 localhost.localdomain dockerd[2599]: time="2026-08-27T09:37:51.695678280+08:00" level=info msg=serving... address=/var/run/docker/containerd/containerd-debug.sock
Aug 27 09:37:51 localhost.localdomain dockerd[2599]: time="2026-08-27T09:37:51.695741810+08:00" level=info msg=serving... address=/var/run/docker/containerd/containerd.sock.ttrpc
Aug 27 09:37:51 localhost.localdomain dockerd[2599]: time="2026-08-27T09:37:51.695798290+08:00" level=info msg=serving... address=/var/run/docker/containerd/containerd.sock
Aug 27 09:37:51 localhost.localdomain dockerd[2599]: time="2026-08-27T09:37:51.695827390+08:00" level=info msg="containerd successfully booted in 0.131865s"
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.701450790+08:00" level=info msg="pickfirstBalancer: HandleSubConnStateChange: 0x2e0fd7962c40, READY" module=grpc
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.710793520+08:00" level=info msg="parsed scheme: \"unix\"" module=grpc
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.710817120+08:00" level=info msg="scheme \"unix\" not registered, fallback to default scheme" module=grpc
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.710947940+08:00" level=info msg="parsed scheme: \"unix\"" module=grpc
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.710957740+08:00" level=info msg="scheme \"unix\" not registered, fallback to default scheme" module=grpc
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.713512460+08:00" level=info msg="ccResolverWrapper: sending new addresses to cc: [{unix:///var/run/docker/containerd/containerd.sock 0 <nil>}]" module=grpc
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.713537200+08:00" level=info msg="ClientConn switching balancer to \"pick_first\"" module=grpc
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.713573310+08:00" level=info msg="pickfirstBalancer: HandleSubConnStateChange: 0x2e0fd7963c90, CONNECTING" module=grpc
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.713691390+08:00" level=info msg="pickfirstBalancer: HandleSubConnStateChange: 0x2e0fd7963c90, READY" module=grpc
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.713721640+08:00" level=info msg="ccResolverWrapper: sending new addresses to cc: [{unix:///var/run/docker/containerd/containerd.sock 0 <nil>}]" module=grpc
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.713731280+08:00" level=info msg="ClientConn switching balancer to \"pick_first\"" module=grpc
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.713758600+08:00" level=info msg="pickfirstBalancer: HandleSubConnStateChange: 0x2e0fd7fd0050, CONNECTING" module=grpc
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.713834090+08:00" level=info msg="pickfirstBalancer: HandleSubConnStateChange: 0x2e0fd7fd0050, READY" module=grpc
Aug 27 09:37:51 localhost.localdomain dockerd[2599]: time="2026-08-27T09:37:51.714845520+08:00" level=info msg="subscribe ctx=context.Background.WithValue(transport.connectionKey, *net.UnixConn).WithValue(peer.peerKey, *peer.Peer).WithCancel.WithValue(metadata.mdIncomi>
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.918532330+08:00" level=info msg="Graph migration to content-addressability took 0.00 seconds"
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.918907510+08:00" level=warning msg="Your kernel does not support cgroup memory limit"
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.918924820+08:00" level=warning msg="Your kernel does not support cgroup hugetlb limit"
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.918931940+08:00" level=warning msg="Unable to find cpu cgroup in mounts"
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.918937360+08:00" level=warning msg="Unable to find blkio cgroup in mounts"
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.918943330+08:00" level=warning msg="Unable to find cpuset cgroup in mounts"
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.918987450+08:00" level=warning msg="mountpoint for pids not found"
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.919011750+08:00" level=warning msg="mountpoint for files not found"
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.919765950+08:00" level=info msg="stopping event stream following graceful shutdown" error="context canceled" module=libcontainerd namespace=plugins.moby
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.922941710+08:00" level=info msg="stopping healthcheck following graceful shutdown" module=libcontainerd
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.923944120+08:00" level=info msg="pickfirstBalancer: HandleSubConnStateChange: 0x2e0fd7fd0050, TRANSIENT_FAILURE" module=grpc
Aug 27 09:37:51 localhost.localdomain dockerd[2594]: time="2026-08-27T09:37:51.923971410+08:00" level=info msg="pickfirstBalancer: HandleSubConnStateChange: 0x2e0fd7fd0050, CONNECTING" module=grpc
Aug 27 09:37:52 localhost.localdomain dockerd[2594]: Error starting daemon: Devices cgroup isn't mounted
Aug 27 09:37:52 localhost.localdomain systemd[1]: docker.service: Main process exited, code=exited, status=1/FAILURE
░░ Subject: Unit process exited
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░
░░ An ExecStart= process belonging to unit docker.service has exited.
░░
░░ The process' exit code is 'exited' and its exit status is 1.
Aug 27 09:37:52 localhost.localdomain systemd[1]: docker.service: Failed with result 'exit-code'.
░░ Subject: Unit failed
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░
░░ The unit docker.service has entered the 'failed' state with result 'exit-code'.
Aug 27 09:37:52 localhost.localdomain systemd[1]: Failed to start Docker Application Container Engine.
░░ Subject: A start job for unit docker.service has failed
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░
░░ A start job for unit docker.service has finished with a failure.
░░
░░ The job identifier is 1952 and the job result is failed.
[root@localhost ~]#
[root@localhost ~]#


rc3 版本还是 这个bug, 望尽快解决
[root@localhost ~]#
[root@localhost ~]# uname -r
6.6.0-169.0.0.2.oe2609.x86_64
[root@localhost ~]#
[root@localhost ~]#
[root@localhost ~]# uname -a
Linux localhost.localdomain 6.6.0-169.0.0.2.oe2609.x86_64 #1 SMP Fri Aug 28 00:42:38 CST 2026 x86_64 x86_64 x86_64 GNU/Linux
[root@localhost ~]#
[root@localhost ~]#
[root@localhost ~]# yum install -y docker-engine
Last metadata expiration check: 0:52:42 ago on Tue 01 Sep 2026 04:17:38 PM CST.
Dependencies resolved.
==============================================================================================================================================================================================================================================================================
Package Architecture Version Repository Size
==============================================================================================================================================================================================================================================================================
Installing:
docker-engine x86_64 2:18.09.0-355.oe2609 OS 48 M
Installing dependencies:
libnetwork x86_64 25.0.14-2.oe2609 OS 894 k
libtool-ltdl x86_64 2.5.4-3.oe2609 OS 32 k
Transaction Summary
==============================================================================================================================================================================================================================================================================
Install 3 Packages
Total download size: 49 M
Installed size: 191 M
Downloading Packages:
(1/3): libtool-ltdl-2.5.4-3.oe2609.x86_64.rpm 1.8 MB/s | 32 kB 00:00
(2/3): libnetwork-25.0.14-2.oe2609.x86_64.rpm 13 MB/s | 894 kB 00:00
(3/3): docker-engine-18.09.0-355.oe2609.x86_64.rpm 46 MB/s | 48 MB 00:01
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total 46 MB/s | 49 MB 00:01
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
Preparing : 1/1
Installing : libtool-ltdl-2.5.4-3.oe2609.x86_64 1/3
Installing : libnetwork-25.0.14-2.oe2609.x86_64 2/3
Installing : docker-engine-2:18.09.0-355.oe2609.x86_64 3/3
Running scriptlet: docker-engine-2:18.09.0-355.oe2609.x86_64 3/3
Created symlink /etc/systemd/system/multi-user.target.wants/docker.service → /usr/lib/systemd/system/docker.service.
Job for docker.service failed because the control process exited with error code.
See "systemctl status docker.service" and "journalctl -xeu docker.service" for details.
Verifying : docker-engine-2:18.09.0-355.oe2609.x86_64 1/3
Verifying : libnetwork-25.0.14-2.oe2609.x86_64 2/3
Verifying : libtool-ltdl-2.5.4-3.oe2609.x86_64 3/3
Installed:
docker-engine-2:18.09.0-355.oe2609.x86_64 libnetwork-25.0.14-2.oe2609.x86_64 libtool-ltdl-2.5.4-3.oe2609.x86_64
Complete!
[root@localhost ~]#
[root@localhost ~]#
[root@localhost ~]#
[root@localhost ~]# systemctl status docker.service
× docker.service - Docker Application Container Engine
Loaded: loaded (/usr/lib/systemd/system/docker.service; enabled; preset: disabled)
Active: failed (Result: exit-code) since Tue 2026-09-01 17:10:25 CST; 13s ago
Docs: https://docs.docker.com
Main PID: 2386 (code=exited, status=1/FAILURE)
CPU: 181ms
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.865742714+08:00" level=warning msg="mountpoint for pids not found"
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.865782601+08:00" level=warning msg="mountpoint for files not found"
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.866293924+08:00" level=info msg="stopping event stream following graceful shutdown" error="context canceled" module=libcontainerd namespace=plugins.moby
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.866291917+08:00" level=info msg="stopping healthcheck following graceful shutdown" module=libcontainerd
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.866580445+08:00" level=info msg="pickfirstBalancer: HandleSubConnStateChange: 0x3e0587294e60, TRANSIENT_FAILURE" module=grpc
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.866598982+08:00" level=info msg="pickfirstBalancer: HandleSubConnStateChange: 0x3e0587294e60, CONNECTING" module=grpc
Sep 01 17:10:25 localhost.localdomain dockerd[2386]: Error starting daemon: Devices cgroup isn't mounted
Sep 01 17:10:25 localhost.localdomain systemd[1]: docker.service: Main process exited, code=exited, status=1/FAILURE
Sep 01 17:10:25 localhost.localdomain systemd[1]: docker.service: Failed with result 'exit-code'.
Sep 01 17:10:25 localhost.localdomain systemd[1]: Failed to start Docker Application Container Engine.
[root@localhost ~]#
[root@localhost ~]#
[root@localhost ~]#
[root@localhost ~]#
[root@localhost ~]# journalctl -xeu docker.service
Sep 01 17:10:24 localhost.localdomain dockerd[2395]: time="2026-09-01T17:10:24.838054864+08:00" level=info msg=serving... address=/var/run/docker/containerd/containerd-debug.sock
Sep 01 17:10:24 localhost.localdomain dockerd[2395]: time="2026-09-01T17:10:24.838115335+08:00" level=info msg=serving... address=/var/run/docker/containerd/containerd.sock.ttrpc
Sep 01 17:10:24 localhost.localdomain dockerd[2395]: time="2026-09-01T17:10:24.838167830+08:00" level=info msg=serving... address=/var/run/docker/containerd/containerd.sock
Sep 01 17:10:24 localhost.localdomain dockerd[2395]: time="2026-09-01T17:10:24.838190142+08:00" level=info msg="containerd successfully booted in 0.022121s"
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.838335348+08:00" level=info msg="pickfirstBalancer: HandleSubConnStateChange: 0x3e058767e8d0, READY" module=grpc
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.849021035+08:00" level=info msg="parsed scheme: \"unix\"" module=grpc
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.849052151+08:00" level=info msg="scheme \"unix\" not registered, fallback to default scheme" module=grpc
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.849108224+08:00" level=info msg="parsed scheme: \"unix\"" module=grpc
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.849117167+08:00" level=info msg="scheme \"unix\" not registered, fallback to default scheme" module=grpc
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.849171506+08:00" level=info msg="ccResolverWrapper: sending new addresses to cc: [{unix:///var/run/docker/containerd/containerd.sock 0 <nil>}]" module=grpc
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.849197665+08:00" level=info msg="ClientConn switching balancer to \"pick_first\"" module=grpc
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.849235834+08:00" level=info msg="pickfirstBalancer: HandleSubConnStateChange: 0x3e05879841a0, CONNECTING" module=grpc
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.849325664+08:00" level=info msg="ccResolverWrapper: sending new addresses to cc: [{unix:///var/run/docker/containerd/containerd.sock 0 <nil>}]" module=grpc
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.849348405+08:00" level=info msg="ClientConn switching balancer to \"pick_first\"" module=grpc
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.849366621+08:00" level=info msg="pickfirstBalancer: HandleSubConnStateChange: 0x3e05879841a0, READY" module=grpc
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.849383328+08:00" level=info msg="pickfirstBalancer: HandleSubConnStateChange: 0x3e0587294e60, CONNECTING" module=grpc
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.851082005+08:00" level=info msg="pickfirstBalancer: HandleSubConnStateChange: 0x3e0587294e60, READY" module=grpc
Sep 01 17:10:24 localhost.localdomain dockerd[2395]: time="2026-09-01T17:10:24.851760596+08:00" level=info msg="subscribe ctx=context.Background.WithValue(transport.connectionKey, *net.UnixConn).WithValue(peer.peerKey, *peer.Peer).WithCancel.WithValue(metadata.mdIncomi>
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.853951290+08:00" level=info msg="[graphdriver] using prior storage driver: overlay2"
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.865518918+08:00" level=info msg="Graph migration to content-addressability took 0.00 seconds"
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.865663800+08:00" level=warning msg="Your kernel does not support cgroup memory limit"
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.865687023+08:00" level=warning msg="Your kernel does not support cgroup hugetlb limit"
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.865694862+08:00" level=warning msg="Unable to find cpu cgroup in mounts"
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.865700203+08:00" level=warning msg="Unable to find blkio cgroup in mounts"
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.865704954+08:00" level=warning msg="Unable to find cpuset cgroup in mounts"
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.865742714+08:00" level=warning msg="mountpoint for pids not found"
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.865782601+08:00" level=warning msg="mountpoint for files not found"
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.866293924+08:00" level=info msg="stopping event stream following graceful shutdown" error="context canceled" module=libcontainerd namespace=plugins.moby
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.866291917+08:00" level=info msg="stopping healthcheck following graceful shutdown" module=libcontainerd
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.866580445+08:00" level=info msg="pickfirstBalancer: HandleSubConnStateChange: 0x3e0587294e60, TRANSIENT_FAILURE" module=grpc
Sep 01 17:10:24 localhost.localdomain dockerd[2386]: time="2026-09-01T17:10:24.866598982+08:00" level=info msg="pickfirstBalancer: HandleSubConnStateChange: 0x3e0587294e60, CONNECTING" module=grpc
Sep 01 17:10:25 localhost.localdomain dockerd[2386]: Error starting daemon: Devices cgroup isn't mounted
Sep 01 17:10:25 localhost.localdomain systemd[1]: docker.service: Main process exited, code=exited, status=1/FAILURE
░░ Subject: Unit process exited
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░
░░ An ExecStart= process belonging to unit docker.service has exited.
░░
░░ The process' exit code is 'exited' and its exit status is 1.
Sep 01 17:10:25 localhost.localdomain systemd[1]: docker.service: Failed with result 'exit-code'.
░░ Subject: Unit failed
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░
░░ The unit docker.service has entered the 'failed' state with result 'exit-code'.
Sep 01 17:10:25 localhost.localdomain systemd[1]: Failed to start Docker Application Container Engine.
░░ Subject: A start job for unit docker.service has failed
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░
░░ A start job for unit docker.service has finished with a failure.
░░
░░ The job identifier is 1510 and the job result is failed.
[root@localhost ~]#
[root@localhost ~]#


AI回答的原因: 你遇到的 Devices cgroup isn't mounted 错误是因为 Docker 旧版不兼容 cgroup v2。
是的,这是个已知问题,因为openEuler-26.09-DevStation的机器使用了cgroup v2,而当前仓库的docker仅支持cgroup v1。如果用户需要使用cgroup v2请使用https://atomgit.com/src-openeuler/moby
编译高版本moby包。详情可参考该issue:
https://atomgit.com/src-openeuler/docker/issues/201




/reason 开发回复, 当前openEuler-26.09-DevStation的机器使用了cgroup v2,而当前仓库的docker仅支持cgroup v1


【缺陷描述】:请补充详细的缺陷问题现象描述
一、缺陷信息
【缺陷所属的os版本】
1.OS版本及分支: openEuler-26.09-DevStation-alpha
2.内核信息: kernel-6.6.0-163.0.0.1.oe2609.src.rpm
【内核版本】
kernel-6.6.0-163.0.0.1
【缺陷所属软件及版本号】
docker-engine-2:18.09.0-353.oe2609
【环境信息】
硬件信息
软件信息
网络信息
【问题复现步骤】
yum install docker-engine
【实际结果】
【期望结果】
无异常信息
【其他相关附件信息】
【缺陷详情及分析指导参考链接】
二、缺陷分析结构反馈
影响性分析说明:
缺陷严重等级:(Critical/High/Moderate/Low)
缺陷根因说明:
受影响版本排查(受影响/不受影响):
openEuler-20.03-LTS-SP4
openEuler-22.03-LTS-SP3
openEuler-22.03-LTS-SP4
openEuler-24.03-LTS
openEuler-24.03-LTS-SP1
openEuler-24.03-LTS-SP2
修复是否涉及abi变化(是/否):
openEuler-20.03-LTS-SP4
openEuler-22.03-LTS-SP3
openEuler-22.03-LTS-SP4
openEuler-24.03-LTS
openEuler-24.03-LTS-SP1
openEuler-24.03-LTS-SP2