@jas0n918 ,@dingwei-hello ,@wang-jialing218 ,@hu-zongtang
issue处理注意事项:
1. 当前issue受影响的分支提交pr时, 须在pr描述中填写当前issue编号进行关联, 否则无法关闭当前issue;
2. 模板内容需要填写完整, 无论是受影响或者不受影响都需要填写完整内容,未引入的分支不需要填写, 否则无法关闭当前issue;
3. 以下为模板中需要填写完整的内容, 请复制到评论区回复, 注: 内容的标题名称(影响性分析说明, openEuler评分, 受影响版本排查(受影响/不受影响), 修复是否涉及abi变化(是/否))不能省略,省略后cve-manager将无法正常解析填写内容.
影响性分析说明:
openEuler评分: (评分和向量)
受影响版本排查(受影响/不受影响):
1.master(2.10.4):
2.openEuler-20.03-LTS-SP1:
3.openEuler-20.03-LTS-SP4:
4.openEuler-22.03-LTS:
5.openEuler-22.03-LTS-Next:
6.openEuler-22.03-LTS-SP1:
7.openEuler-22.03-LTS-SP2:
8.openEuler-22.03-LTS-SP3:
9.openEuler-24.03-LTS:
修复是否涉及abi变化(是/否):
1.master(2.10.4):
2.openEuler-20.03-LTS-SP1:
3.openEuler-20.03-LTS-SP4:
4.openEuler-22.03-LTS:
5.openEuler-22.03-LTS-Next:
6.openEuler-22.03-LTS-SP1:
7.openEuler-22.03-LTS-SP2:
8.openEuler-22.03-LTS-SP3:
9.openEuler-24.03-LTS:
issue处理具体操作请参考:
https://gitee.com/openeuler/cve-manager/blob/master/cve-vulner-manager/doc/md/manual.md
pr关联issue具体操作请参考:
https://gitee.com/help/articles/4142


Hi openMajun_admin, welcome to the openEuler Community.
I'm the Bot here serving you. You can find the instructions on how to interact with me at Here.
If you have any questions, please contact the SIG: sig-message-middleware, and any of the maintainers: @jas0n918 , @dingwei-hello , @wang-jialing218 , @hu-zongtang , @openeuler-ci-bot


| 参考网址 | 关联pr | 状态 | 补丁链接 |
|---|---|---|---|
| https://nvd.nist.gov/vuln/detail/CVE-2022-34321 | |||
| https://ubuntu.com/security/CVE-2022-34321 | None | None | https://discourse.ubuntu.com/c/ubuntu-pro |
| https://www.opencve.io/cve/CVE-2022-34321 | |||
| https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2022-34321 | |||
| https://security-tracker.debian.org/tracker/CVE-2022-34321 |
说明:补丁链接仅供初步排查参考,实际可用性请人工再次确认,补丁下载验证可使用CVE补丁工具。
若补丁不准确,烦请在此issue下评论 '/report-patch 参考网址 补丁链接1,补丁链接2' 反馈正确信息,便于我们不断优化工具,不胜感激。
如 /report-patch https://security-tracker.debian.org/tracker/CVE-2021-3997 https://github.com/systemd/systemd/commit/5b1cf7a9be37e20133c0208005274ce4a5b5c6a1


@dongjiao-joan 请确认分支: master,openEuler-20.03-LTS-SP1,openEuler-20.03-LTS-SP4,openEuler-22.03-LTS,openEuler-22.03-LTS-Next,openEuler-22.03-LTS-SP1,openEuler-22.03-LTS-SP2,openEuler-22.03-LTS-SP3,openEuler-24.03-LTS,openEuler-24.03-LTS-Next 受影响/不受影响.
请确认分支信息是否填写完整,否则将无法关闭当前issue.


经过cve-manager解析,(所有PR均已合入)


一、漏洞信息
漏洞编号:CVE-2022-34321
漏洞归属组件:pulsar
漏洞归属的版本:2.10.4,2.10.6
CVSS评分:
BaseScore:8.2 High
Vector:CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L
漏洞简述:
Improper Authentication vulnerability in Apache Pulsar Proxy allows an attacker to connect to the /proxy-stats endpoint without authentication. The vulnerable endpoint exposes detailed statistics about live connections, along with the capability to modify the logging level of proxied connections without requiring proper authentication credentials.This issue affects Apache Pulsar versions from 2.6.0 to 2.10.5, from 2.11.0 to 2.11.2, from 3.0.0 to 3.0.1, and 3.1.0.The known risks include exposing sensitive information such as connected client IP and unauthorized logging level manipulation which could lead to a denial-of-service condition by significantly increasing the proxy s logging overhead. When deployed via the Apache Pulsar Helm chart within Kubernetes environments, the actual client IP might not be revealed through the load balancer s default behavior, which typically obscures the original source IP addresses when externalTrafficPolicy is being configured to Cluster by default. The /proxy-stats endpoint contains topic level statistics, however, in the default configuration, the topic level statistics aren t known to be exposed.2.10 Pulsar Proxy users should upgrade to at least 2.10.6.2.11 Pulsar Proxy users should upgrade to at least 2.11.3.3.0 Pulsar Proxy users should upgrade to at least 3.0.2.3.1 Pulsar Proxy users should upgrade to at least 3.1.1.Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions. Additionally, it s imperative to recognize that the Apache Pulsar Proxy is not intended for direct exposure to the internet. The architectural design of Pulsar Proxy assumes that it will operate within a secured network environment, safeguarded by appropriate perimeter defenses.
漏洞公开时间:2024-03-13 03:15:47
漏洞创建时间:2024-03-12 20:41:13
漏洞详情参考链接:
https://nvd.nist.gov/vuln/detail/CVE-2022-34321
更多参考(点击展开)
漏洞分析指导链接:
https://atomgit.com/openeuler/cve-manager/blob/master/cve-vulner-manager/doc/md/manual.md
漏洞数据来源:
其他
漏洞补丁信息:
详情(点击展开)
二、漏洞分析结构反馈
影响性分析说明:
Improper Authentication vulnerability in Apache Pulsar Proxy allows an attacker to connect to the /proxy-stats endpoint without authentication. The vulnerable endpoint exposes detailed statistics about live connections, along with the capability to modify the logging level of proxied connections without requiring proper authentication credentials.
openEuler评分:
8.2
Vector:CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L
受影响版本排查(受影响/不受影响):
1.master(2.10.6):不受影响
2.openEuler-20.03-LTS-SP1:不受影响
3.openEuler-20.03-LTS-SP4:不受影响
4.openEuler-22.03-LTS:不受影响
5.openEuler-22.03-LTS-Next:不受影响
6.openEuler-22.03-LTS-SP1:不受影响
7.openEuler-22.03-LTS-SP2:不受影响
8.openEuler-22.03-LTS-SP3:不受影响
9.openEuler-24.03-LTS(2.10.4):受影响
10.openEuler-24.03-LTS-Next(2.10.4):受影响
11.openEuler-22.03-LTS-SP4:不受影响
12.openEuler-24.03-LTS-SP2(2.10.4):受影响
13.openEuler-24.03-LTS-SP1(2.10.4):受影响
14.openEuler-24.03-LTS-SP3(2.10.4):受影响
15.openEuler-24.03-LTS-SP4(2.10.4):受影响
修复是否涉及abi变化(是/否):
1.master(2.10.6):否
2.openEuler-20.03-LTS-SP1:否
3.openEuler-20.03-LTS-SP4:否
4.openEuler-22.03-LTS:否
5.openEuler-22.03-LTS-Next:否
6.openEuler-22.03-LTS-SP1:否
7.openEuler-22.03-LTS-SP2:否
8.openEuler-22.03-LTS-SP3:否
9.openEuler-24.03-LTS(2.10.4):否
10.openEuler-24.03-LTS-Next(2.10.4):否
11.openEuler-22.03-LTS-SP4:否
12.openEuler-24.03-LTS-SP2(2.10.4):否
13.openEuler-24.03-LTS-SP1(2.10.4):否
14.openEuler-24.03-LTS-SP3(2.10.4):否
15.openEuler-24.03-LTS-SP4(2.10.4):否
原因说明:
1.master(2.10.6):不受影响-漏洞代码不存在
2.openEuler-20.03-LTS-SP4:不受影响-组件不存在
3.openEuler-22.03-LTS-SP4:不受影响-组件不存在
4.openEuler-24.03-LTS(2.10.4):不修复-超出修复范围
5.openEuler-24.03-LTS-Next(2.10.4):正常修复
6.openEuler-24.03-LTS-SP1(2.10.4):正常修复
7.openEuler-24.03-LTS-SP2(2.10.4):不修复-超出修复范围
8.openEuler-24.03-LTS-SP3(2.10.4):正常修复
9.openEuler-24.03-LTS-SP4(2.10.4):正常修复