@shinwell_hu ,@yangzhao_kl ,@myeuler ,@cherry530 ,@randy1568
issue处理注意事项:
1. 当前issue受影响的分支提交pr时, 须在pr描述中填写当前issue编号进行关联, 否则无法关闭当前issue;
2. 模板内容需要填写完整, 无论是受影响或者不受影响都需要填写完整内容,未引入的分支不需要填写, 否则无法关闭当前issue;
3. 以下为模板中需要填写完整的内容, 请复制到评论区回复, 注: 内容的标题名称(影响性分析说明, openEuler评分, 受影响版本排查(受影响/不受影响), 修复是否涉及abi变化(是/否), 原因说明)不能省略,省略后cve-manager将无法正常解析填写内容.
影响性分析说明:
openEuler评分: (评分和向量)
受影响版本排查(受影响/不受影响):
1.master(9.0.1):
2.openEuler-20.03-LTS-SP4(7.0.0):
3.openEuler-22.03-LTS-SP3(7.0.0):
4.openEuler-22.03-LTS-SP4(7.0.0):
5.openEuler-24.03-LTS(9.0.1):
6.openEuler-24.03-LTS-Next(9.0.1):
7.openEuler-24.03-LTS-SP1(9.0.1):
修复是否涉及abi变化(是/否):
1.master(9.0.1):
2.openEuler-20.03-LTS-SP4(7.0.0):
3.openEuler-22.03-LTS-SP3(7.0.0):
4.openEuler-22.03-LTS-SP4(7.0.0):
5.openEuler-24.03-LTS(9.0.1):
6.openEuler-24.03-LTS-Next(9.0.1):
7.openEuler-24.03-LTS-SP1(9.0.1):
原因说明:
1.master(9.0.1):
2.openEuler-20.03-LTS-SP4(7.0.0):
3.openEuler-22.03-LTS-SP3(7.0.0):
4.openEuler-22.03-LTS-SP4(7.0.0):
5.openEuler-24.03-LTS(9.0.1):
6.openEuler-24.03-LTS-Next(9.0.1):
7.openEuler-24.03-LTS-SP1(9.0.1):
原因说明填写请参考下方表格(注意:版本是否受影响和版本的原因说明必须对应,例如master版本分支受影响,那原因说明只能是受影响对应的原因之一!):
| 分支状态 | 原因说明 |
|---|---|
| 受影响 | 正常修复 |
| 受影响 | 暂不修复-漏洞仍在分析中 |
| 受影响 | 暂不修复-暂无解决方案或补丁 |
| 受影响 | 暂不修复-待升级版本修复 |
| 受影响 | 不修复-超出修复范围 |
| 受影响 | 不修复-特殊原因导致不再修复 |
| 不受影响 | 不受影响-组件不存在 |
| 不受影响 | 不受影响-已有内置的内联控制或缓解措施 |
| 不受影响 | 不受影响-漏洞代码不能被攻击者触发 |
| 不受影响 | 不受影响-漏洞代码不在执行路径 |
| 不受影响 | 不受影响-漏洞代码不存在 |
issue处理具体操作请参考:
https://gitee.com/openeuler/cve-manager/blob/master/cve-vulner-manager/doc/md/manual.md
pr关联issue具体操作请参考:
https://gitee.com/help/articles/4142


| 参考网址 | 关联pr | 状态 | 补丁链接 |
|---|---|---|---|
| https://nvd.nist.gov/vuln/detail/CVE-2025-23217 | |||
| https://ubuntu.com/security/CVE-2025-23217 | |||
| https://www.opencve.io/cve/CVE-2025-23217 | |||
| https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2025-23217 | |||
| https://security-tracker.debian.org/tracker/CVE-2025-23217 |
说明:抱歉,当前工具暂未找到推荐补丁,请人工查找或者之后评论'/find-patch'尝试再次查找。
若人工查找到补丁,烦请在此issue下评论 '/report-patch 参考网址 补丁链接1,补丁链接2' 便于我们不断优化工具,不胜感激。
如 /report-patch https://security-tracker.debian.org/tracker/CVE-2021-3997 https://github.com/systemd/systemd/commit/5b1cf7a9be37e20133c0208005274ce4a5b5c6a1


原因说明:
1.master:正常修复
2.openEuler-20.03-LTS-SP4:正常修复
3.openEuler-22.03-LTS-SP3:不修复-超出修复范围
4.openEuler-22.03-LTS-SP4:正常修复
5.openEuler-24.03-LTS:不修复-超出修复范围
6.openEuler-24.03-LTS-Next:正常修复
7.openEuler-24.03-LTS-SP1:正常修复
8.openEuler-24.03-LTS-SP2:不修复-超出修复范围
9.openEuler-24.03-LTS-SP3:正常修复
10.openEuler-24.03-LTS-SP4:正常修复


@randy1568 经过 cve-manager 解析, 已分析的内容如下表所示:
| 状态 | 分析项目 | 内容 |
|---|---|---|
| 已分析 | 1.影响性分析说明 | mitmproxy is a interactive TLS-capable intercepting HTTP proxy for penetration testers and software developers and mitmweb is a web-based interface for mitmproxy. In mitmweb 11.1.1 and below, a malicious client can use mitmweb s proxy server (bound to *:8080 by default) to access mitmweb s internal API (bound to 127.0.0.1:8081 by default). In other words, while the cannot access the API directly, they can access the API through the proxy. An attacker may be able to escalate this SSRF-style access to remote code execution. The mitmproxy and mitmdump tools are unaffected. Only mitmweb is affected. This vulnerability has been fixed in mitmproxy 11.1.2 and above. Users are advised to upgrade. There are no known workarounds for this vulnerability. |
| 已分析 | 2.openEulerScore | 8.2 |
| 已分析 | 3.openEulerVector | AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N |
| 已分析 | 4.受影响版本排查 | master:受影响,openEuler-20.03-LTS-SP4:受影响,openEuler-22.03-LTS-SP3:受影响,openEuler-22.03-LTS-SP4:受影响,openEuler-24.03-LTS:受影响,openEuler-24.03-LTS-Next:受影响,openEuler-24.03-LTS-SP1:受影响,openEuler-24.03-LTS-SP2:受影响,openEuler-24.03-LTS-SP3:受影响,openEuler-24.03-LTS-SP4:受影响 |
| 已分析 | 5.是否涉及abi变化 | master:否,openEuler-20.03-LTS-SP4:否,openEuler-22.03-LTS-SP3:否,openEuler-22.03-LTS-SP4:否,openEuler-24.03-LTS-Next:否,openEuler-24.03-LTS-SP1:否,openEuler-24.03-LTS-SP2:否,openEuler-24.03-LTS:否,openEuler-24.03-LTS-SP3:否,openEuler-24.03-LTS-SP4:否 |
| 已分析 | 6.原因说明 | master:正常修复,openEuler-20.03-LTS-SP4:正常修复,openEuler-22.03-LTS-SP3:不修复-超出修复范围,openEuler-22.03-LTS-SP4:正常修复,openEuler-24.03-LTS:不修复-超出修复范围,openEuler-24.03-LTS-Next:正常修复,openEuler-24.03-LTS-SP1:正常修复,openEuler-24.03-LTS-SP2:不修复-超出修复范围,openEuler-24.03-LTS-SP3:正常修复,openEuler-24.03-LTS-SP4:正常修复 |
请确认分析内容的准确性, 确认无误后, 您可以进行后续步骤, 否则您可以继续分析.


经过cve-manager解析,部分分支PR未合入,如红色字体所示:
原因说明:
1.master:正常修复(PR未合入)
2.openEuler-20.03-LTS-SP4:正常修复(PR未合入)
3.openEuler-22.03-LTS-SP3:不修复-超出修复范围
4.openEuler-22.03-LTS-SP4:正常修复(PR未合入)
5.openEuler-24.03-LTS:不修复-超出修复范围
6.openEuler-24.03-LTS-Next:正常修复(PR未合入)
7.openEuler-24.03-LTS-SP1:正常修复(PR未合入)
8.openEuler-24.03-LTS-SP2:不修复-超出修复范围
9.openEuler-24.03-LTS-SP3:正常修复(PR未合入)
10.openEuler-24.03-LTS-SP4:正常修复(PR未合入)


一、漏洞信息
漏洞编号:CVE-2025-23217
漏洞归属组件:python-mitmproxy
漏洞归属的版本:7.0.0,9.0.1
CVSS评分:
BaseScore:0.0 None
Vector:
漏洞简述:
mitmproxy is a interactive TLS-capable intercepting HTTP proxy for penetration testers and software developers and mitmweb is a web-based interface for mitmproxy. In mitmweb 11.1.1 and below, a malicious client can use mitmweb s proxy server (bound to
*:8080by default) to access mitmweb s internal API (bound to127.0.0.1:8081by default). In other words, while the cannot access the API directly, they can access the API through the proxy. An attacker may be able to escalate this SSRF-style access to remote code execution. The mitmproxy and mitmdump tools are unaffected. Only mitmweb is affected. This vulnerability has been fixed in mitmproxy 11.1.2 and above. Users are advised to upgrade. There are no known workarounds for this vulnerability.漏洞公开时间:2025-02-07 02:15:32
漏洞创建时间:2025-02-08 03:23:09
漏洞详情参考链接:
https://nvd.nist.gov/vuln/detail/CVE-2025-23217
更多参考(点击展开)
漏洞分析指导链接:
https://atomgit.com/openeuler/cve-manager/blob/master/cve-vulner-manager/doc/md/manual.md
漏洞数据来源:
openBrain开源漏洞感知系统
漏洞补丁信息:
详情(点击展开)
无
二、漏洞分析结构反馈
影响性分析说明:
mitmproxy is a interactive TLS-capable intercepting HTTP proxy for penetration testers and software developers and mitmweb is a web-based interface for mitmproxy. In mitmweb 11.1.1 and below, a malicious client can use mitmweb s proxy server (bound to
*:8080by default) to access mitmweb s internal API (bound to127.0.0.1:8081by default). In other words, while the cannot access the API directly, they can access the API through the proxy. An attacker may be able to escalate this SSRF-style access to remote code execution. The mitmproxy and mitmdump tools are unaffected. Only mitmweb is affected. This vulnerability has been fixed in mitmproxy 11.1.2 and above. Users are advised to upgrade. There are no known workarounds for this vulnerability.openEuler评分:
8.2
Vector:CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
受影响版本排查(受影响/不受影响):
1.master(9.0.1):受影响
2.openEuler-20.03-LTS-SP4(7.0.0):受影响
3.openEuler-22.03-LTS-SP3(7.0.0):受影响
4.openEuler-22.03-LTS-SP4(7.0.0):受影响
5.openEuler-24.03-LTS(9.0.1):受影响
6.openEuler-24.03-LTS-Next(9.0.1):受影响
7.openEuler-24.03-LTS-SP1(9.0.1):受影响
8.openEuler-24.03-LTS-SP2(9.0.1):受影响
9.openEuler-24.03-LTS-SP3(9.0.1):受影响
10.openEuler-24.03-LTS-SP4(9.0.1):受影响
修复是否涉及abi变化(是/否):
1.master(9.0.1):否
2.openEuler-20.03-LTS-SP4(7.0.0):否
3.openEuler-22.03-LTS-SP3(7.0.0):否
4.openEuler-22.03-LTS-SP4(7.0.0):否
5.openEuler-24.03-LTS-Next(9.0.1):否
6.openEuler-24.03-LTS-SP1(9.0.1):否
7.openEuler-24.03-LTS-SP2(9.0.1):否
8.openEuler-24.03-LTS(9.0.1):否
9.openEuler-24.03-LTS-SP3(9.0.1):否
10.openEuler-24.03-LTS-SP4(9.0.1):否
原因说明:
1.master(9.0.1):正常修复
2.openEuler-20.03-LTS-SP4(7.0.0):正常修复
3.openEuler-22.03-LTS-SP3(7.0.0):不修复-超出修复范围
4.openEuler-22.03-LTS-SP4(7.0.0):正常修复
5.openEuler-24.03-LTS(9.0.1):不修复-超出修复范围
6.openEuler-24.03-LTS-Next(9.0.1):正常修复
7.openEuler-24.03-LTS-SP1(9.0.1):正常修复
8.openEuler-24.03-LTS-SP2(9.0.1):不修复-超出修复范围
9.openEuler-24.03-LTS-SP3(9.0.1):正常修复
10.openEuler-24.03-LTS-SP4(9.0.1):正常修复